Unbuntu 下编译安装 PHP 必要库的安装

编译环境

sudo apt-get install build-essential

xml

sudo apt-get install libxml2-dev

pcre

sudo apt-get install libpcre3-dev

jpeg

sudo apt-get install libjpeg62-dev

freetype

sudo apt-get install libfreetype6-dev

png

sudo apt-get install libpng12-dev libpng3 libpnglite-dev

iconv

sudo apt-get install libiconv-hook-dev libiconv-hook1

mycrypt

sudo apt-get install libmcrypt-dev libmcrypt4

mhash

sudo apt-get install libmhash-dev libmhash2

openssl

sudo apt-get install libltdl-dev libssl-dev

curl

sudo apt-get install libcurl4-openssl-dev

mysql

sudo apt-get install libmysqlclient-dev

imagick

sudo apt-get install libmagickcore-dev libmagickwand-dev

ubuntu 无法找到 iconv

sudo ln -s /usr/lib/libiconv_hook.so.1.0.0 /usr/lib/libiconv.so
sudo ln -s /usr/lib/libiconv_hook.so.1.0.0 /usr/lib/libiconv.so.1

安装PHP扩展

sudo apt-get install autoconf automake m4